Minetest logo

IRC log for #minetest, 2021-03-18

| Channels | #minetest index | Today | | Google Search | Plaintext

All times shown according to UTC.

Time Nick Message
00:01 MTDiscord <Warr1024> If it's more than one server then it might be significant to point out the common factor between all of them...
00:14 kilbith joined #minetest
00:16 kilbith <Wuzzy>Extexo: it is not possible to get rid of the underline
00:16 sfan5 @Bastrabun do you happen to be here?
00:16 kilbith wrong, you can get rid of the underline by setting a `hovercolor` in the <action> tag in hypertext[]
00:17 Wuzzy o_O
00:17 Wuzzy hovercolor? thats a ... surprise
00:17 kilbith https://www.youtube.com/watch?v=_AtifpDQ-5M
00:17 kilbith (first time I presented hypertext from the EvidenceB labs)
00:17 Wuzzy its weird a property called "hovercolor" kills the underline
00:19 kilbith Wuzzy: both `color` or `hovercolor` actually
00:19 Wuzzy but what if i want to only change the color but not the underline?
00:19 Wuzzy this behavior does not seem to be documented
00:20 kilbith I guess that's not possible
00:20 Wuzzy its surprising behavior
00:20 kilbith underlined hyperlinks are very HTML 3/4 anyway
00:20 Wuzzy lol
00:20 Wuzzy we dont even use HTML 1.0 😀
00:21 kilbith who are still using underlined links in 2021?
00:21 Wuzzy current year argument
00:21 kilbith (except RMS)
00:21 kilbith true
00:22 kilbith hypertext is still very complex as it is
00:32 galex-713 joined #minetest
00:38 galex-713_ joined #minetest
00:41 MTDiscord <Bastrabun> sfan5: I'm "here" via discord. I saw on the forum that you took my IP off the blacklist: Thanks! Wonder how it got there
00:47 delta23 joined #minetest
00:49 galex-713 joined #minetest
00:49 Ruud joined #minetest
01:02 MTDiscord1 joined #minetest
01:02 galex-713_ joined #minetest
01:04 sfan5 @Bastrabun there's another thing: I noticed your server sometimes "misses" an announce (10min between requests, not 5); do you see anything in your logs regading that? timeouts?
01:04 timdorohin joined #minetest
01:06 timdorohin hi
01:06 timdorohin set_rotation() aren't working on attached entities
01:06 timdorohin is this a correct behavior?
01:07 galex-713 joined #minetest
01:09 submariner joined #minetest
01:10 MTDiscord <Bastrabun> sfan5: yes, I see a lot of timeouts. I put the logs into the forum thread in the hopes of help. Not the thread were you posted the "solved" message regarding the ddos, but the one where I described the intial problem
01:11 MTDiscord <Bastrabun> Here: https://forum.minetest.net/viewtopic.php?f=6&amp;t=25813
01:12 MTDiscord <Bastrabun> It's usually Timeout, with response code 0 or 100
01:21 galex-713 joined #minetest
01:27 galex-713_ joined #minetest
01:46 kilbith_ joined #minetest
02:00 galex-713 joined #minetest
02:06 galex-713_ joined #minetest
02:39 leo_rockway joined #minetest
03:59 Surfer2011 joined #minetest
04:00 MTDiscord joined #minetest
05:31 NathanS21 joined #minetest
06:06 dzho joined #minetest
06:07 Flabb joined #minetest
06:17 olliy joined #minetest
06:20 SX_ joined #minetest
06:26 SX joined #minetest
08:00 ShadowNinja joined #minetest
08:21 TomTom joined #minetest
08:28 submariner joined #minetest
08:40 MadScientist joined #minetest
09:20 FeXoR joined #minetest
09:21 hlqkj joined #minetest
09:44 delta23 joined #minetest
09:49 twoelk joined #minetest
10:07 timdorohin joined #minetest
10:29 andrew joined #minetest
10:33 Fixer joined #minetest
10:37 calcul0n joined #minetest
10:47 delta23 joined #minetest
10:51 celeron55 joined #minetest
10:54 SwissalpS joined #minetest
10:54 andrew joined #minetest
10:54 celeron55 joined #minetest
11:09 Dyedefra joined #minetest
11:12 timdorohin joined #minetest
11:17 kevr joined #minetest
11:26 Dyedefra joined #minetest
11:26 calcul0n_ joined #minetest
11:49 absurb joined #minetest
11:53 proller joined #minetest
11:56 tech_exorcist joined #minetest
12:01 erlehmann joined #minetest
12:04 Verticen joined #minetest
12:04 tech_exorcist joined #minetest
12:06 sfan5 @Bastrabun yeah I saw that but I thought those were fixed by now, do you happen to have curl_timeout set in your config? to what value?
12:08 MTDiscord <Jonathon> @Bastranoob
12:12 MTDiscord <Bastrabun> No, it's not set
12:13 MTDiscord <Bastrabun> I had set the serverlist_url for testing and I have ipv6_server and enable_ipv6 set to true.
12:14 MTDiscord <Bastrabun> Should I upload my minetest.conf to somewhere? (without settings for specific mods)
12:15 MTDiscord <Bastrabun> I also have a testserver on the same machine, I could let it announce to the list, too. On the testserver I can change values at your command
12:17 sfan5 not needed but please try with curl_timeout = 30000
12:17 MTDiscord <Bastrabun> (I reset my nickname to Bastrabun, so I can be pinged more easily)
12:17 sfan5 (it's been showing as Bastrabun on this side always)
12:19 MTDiscord <Bastrabun> Ok, I /set curl_timeout 30000
12:20 sfan5 just checked the source, yes that should take effect at runtime
12:23 MTDiscord <Bastrabun> Should I watch the log?
12:25 sfan5 I'll do that on my side
12:30 v32itas joined #minetest
12:47 Telesight joined #minetest
12:55 timdorohin joined #minetest
13:53 kamdard joined #minetest
14:23 Wuzzy joined #minetest
14:42 ronoaldo joined #minetest
14:57 Someguy123 joined #minetest
15:01 FeXoR joined #minetest
15:13 ircSparky joined #minetest
15:17 MadScientist joined #minetest
15:18 leo_rockway joined #minetest
16:01 Hawk777 joined #minetest
16:04 jimender2 joined #minetest
16:12 ronoaldo joined #minetest
16:35 I_am_6r1d joined #minetest
16:52 ramirez joined #minetest
16:53 delta23 joined #minetest
17:02 kevr joined #minetest
17:03 timdorohin okay, after some browsing throught server code and lua bindings i've found that yes, ObjectRef:set_rotation and it c++ counterpart UnitSAO::set_rotation() ain't doing any shit when object is atached to another
17:04 Krock yes that's true
17:04 Krock because there's no matrix calculations on server-side and the server just deals with the entity positions directly for simplicity
17:05 Krock moreover there's no rendering engine to load models which then could be used for attaching stuff to bones
17:07 timdorohin isn't in more logical to allow set/get_rotation to work with attach rotation?
17:07 timdorohin *it
17:08 timdorohin 'cuz right nowto change attached object rotation we need to reattach it
17:12 timdorohin i understand that after rotation change server would send the same thing it would send if we reattached object, but it isn't about efficiency right now, it is about api consistency
17:24 Krock well, set_attach is a very old API and set_rotation was only introduced in 0.5.0-dev which later became 5.0.0
17:25 Krock currently looking for an issue into this direction
17:25 timdorohin Krock: what should i do with that? open an issue on github? go to minetest-dev channel and ask somebody about api change?
17:25 Krock pretty sure there's already an issue about it
17:25 Krock at least I think I've heard this complaint before
17:26 timdorohin patch is really something like 10 lines for both get/set_rotation
17:26 timdorohin and isn't even change anything in lua api
17:27 Krock > If an entity is added to another entity, a call to set_rotation() on the child entity will not override the attach rotation.
17:27 Krock #7395  looks like this is intentional
17:27 ShadowBot https://github.com/minetest/minetest/issues/7395 -- Add Lua methods 'set_rotation()' and 'get_rotation()' by DevyHeavy
17:28 Talkless joined #minetest
17:28 FeXoR joined #minetest
17:30 Krock but I really cannot find any issue that would request set_rotation() to also change set_attach() rotation on call...
18:12 timdorohin Krock: right now i'm messing (and failing) around script-defined meshless entities
18:13 Krock those support attachments as well. take devtest as an example
18:14 Krock it has an entity spawner and object chain tool which does the attachment stuff
18:15 proller joined #minetest
18:17 timdorohin well, you didn't understant what i mean - i'm trying to make complex entity from simple ones and that is where i startet to whine about set/get_rotation and so on
18:18 timdorohin also we can't add bones from script
18:19 timdorohin so i'm using invicible entities as hacky replacement
18:21 Krock yes, there's indeed no custom bone support. blender models are recommended for such things, and I can imagine using many small objects will be kinda tricky to implement
18:28 olliy joined #minetest
18:50 MTDiscord <appguru> there is custom bone support
18:51 MTDiscord <appguru> you just have to generate a .b3d and send it via dynamic_add_media
18:51 MTDiscord <appguru> it's not beautiful, but it should work
18:51 sfan5 wat
19:06 Krock i.e. build your own model binaries
19:38 j joined #minetest
19:44 Markow joined #minetest
19:52 Gustavo6046 joined #minetest
20:08 homthack joined #minetest
20:28 Fractalis joined #minetest
20:48 proller joined #minetest
20:49 tech_exorcist assuming that 1. the time is 12:00; 2. time_speed is set to 0; 3. the game is Minetest Game; 4. the mapgen is v6; 5. the version of both Minetest and Minetest game is 5.3.0-<something>; how far deep will sunlight go in a straight hole dug in the ground? in my world, it seems like it doesn't go any deeper than roughly 2100 blocks, but what's the exact number?
20:51 tech_exorcist more like -2200
20:54 MTDiscord <Jonathon> you might need to use fixlight or if you have it installed /mapfix right above where it goes dark
21:02 Krock you could use VoxelManip:set_light_data() to fool Minetest into thinking that there's sunlight down there
21:03 Krock but usually /fixlight or whatever it is called, might remove the sunlight if the mapblock above does not have full sunlight
21:03 Krock (i.e. worsens the situation)
21:04 Krock there should not be a limit if the sunlight is propagated in a straight linke, but some calculation bugs might prevent that
21:04 erlehmann joined #minetest
21:13 Verticen joined #minetest
21:14 Wuzzy !seen texmex
21:14 MinetestBot Wuzzy: texmex was last seen at 2021-01-18 09:08:15 UTC on #minetest-hub
21:15 Krock !seen Wuzzy
21:15 MinetestBot Krock: wuzzy was last seen at 2021-03-18 21:14:27 UTC on #minetest
21:15 Wuzzy lol
21:27 riff-IRC joined #minetest
21:29 sec^nd joined #minetest
21:37 jonadab joined #minetest
21:57 tech_exorcist @Jonathon and Krock: thanks! :D
22:00 Taserfac1 joined #minetest
22:00 Lunatrius` joined #minetest
22:27 erstazi joined #minetest
23:20 Taoki joined #minetest
23:26 somtalgutoo I accidentally unplugged my PC while running Minetest.  Now it won't load the world I was running at the time it shut down.  When I try to load it, it just immediately shuts down Minetest.  I can reopen Minetest and open other worlds.  Any initial suggestions on what I should do first?  I put a lot of time into this world, and didn't back it up.  :(
23:27 MTDiscord <Benrob0329> Any errors?
23:27 VanessaE ignore_world_load_errors = true
23:27 VanessaE in minetest.conf
23:27 VanessaE should be enough to get it to load
23:27 VanessaE but it may be corrupt
23:27 sfan5 make a backup first in any case
23:28 VanessaE indeed.
23:34 timdorohin minetest seems to screw up pretty normal wavefront obj model https://imgur.com/a/0XstnZY
23:35 MTDiscord <GreenXenith> Bad uv mapping
23:35 VanessaE heh, nice glitch :D
23:35 MTDiscord <GreenXenith> Or, lack thereof I believe
23:36 MTDiscord <GreenXenith> I dont remember how exactly but you can create visual static on meshes with improper UV maps. Makes for potentially neat usecases.
23:38 timdorohin how TF UV mapping can break triangles rendering?
23:39 MTDiscord <GreenXenith> Well I dont know about the massive triangle on the top right
23:39 VanessaE this looks more like a driver failure
23:39 VanessaE bad uv mapping wouldn't cause thids
23:39 VanessaE -d
23:39 MTDiscord <GreenXenith> That one is strange, but the other screwed up part of the model looks near identical to stuff ive experienced with bad UV maps.
23:39 VanessaE it would just cause the model's textures to look funky
23:39 MTDiscord <GreenXenith> Its less a bad UV map, more missing
23:40 MTDiscord <GreenXenith> I think it has something to do with if it expects a UV map but you dont give it one
23:40 VanessaE huh.
23:40 MTDiscord <GreenXenith> or if the UV is scaled to 0
23:40 VanessaE that's a new one on me
23:40 MTDiscord <GreenXenith> I dont remember exactly, all I know is I wanted to try it again eventually to get some neat effects
23:44 timdorohin minetest doesn't support GLTF, right?
23:47 timdorohin or wiki is outdated?
23:48 sfan5 correct, it doesn't
23:55 swift110 joined #minetest
23:56 swift110 joined #minetest

| Channels | #minetest index | Today | | Google Search | Plaintext