Minetest logo

IRC log for #minetest, 2020-07-01

| Channels | #minetest index | Today | | Google Search | Plaintext

All times shown according to UTC.

Time Nick Message
00:02 illwieckz joined #minetest
00:05 appguru1 joined #minetest
00:29 Verticen joined #minetest
00:31 Taoki joined #minetest
00:39 Itz-Noah joined #minetest
00:39 Itz-Noah joined #minetest
01:20 Verticen joined #minetest
01:51 Verticen joined #minetest
01:59 jluc joined #minetest
02:24 YuGiOhJCJ joined #minetest
02:31 DrFrankenstone joined #minetest
02:33 oil_boi joined #minetest
02:33 DrFrankenstone__ joined #minetest
03:06 ItzNoah joined #minetest
03:06 ItzNoah joined #minetest
03:57 tnewman6 joined #minetest
04:12 tnewman joined #minetest
04:56 tnewman8 joined #minetest
05:08 Verticen joined #minetest
06:31 TomTom joined #minetest
06:48 greeter joined #minetest
06:52 absurb joined #minetest
07:01 SX_ joined #minetest
07:01 calcul0n joined #minetest
07:17 greeter joined #minetest
07:22 calcul0n joined #minetest
07:24 calcul0n joined #minetest
07:30 FeXoR joined #minetest
07:31 DrFrankenstone joined #minetest
07:31 Flabb joined #minetest
07:34 greeter joined #minetest
08:00 ShadowNinja joined #minetest
08:02 greeter joined #minetest
08:22 greeter joined #minetest
08:59 SwissalpS joined #minetest
09:01 Verticen joined #minetest
09:10 oil_boi joined #minetest
09:11 oil_boi direct3d9 completely locks me out of the game unless I wipe the conf file of that setting
09:12 oil_boi but d38 works, wat
09:21 oil_boi joined #minetest
09:33 DrFrankenstone_ joined #minetest
09:35 gry_ joined #minetest
09:59 DrFrankenstone joined #minetest
10:05 tnewman joined #minetest
10:11 Flabb joined #minetest
10:14 erlehmann joined #minetest
10:17 Kimapr joined #minetest
10:19 Vili_ joined #minetest
10:37 Vili_ joined #minetest
11:12 absurb joined #minetest
11:16 Kimapr_ joined #minetest
11:19 FeXoR joined #minetest
11:32 Fixer joined #minetest
11:36 oil_boi sfan5, I just found an optimization, inside an optimization, inside an optimization
11:38 oil_boi bumped the redstone power level up to 16 states and this new method is faster, with 20 torches and massive debug output of everything that every torch is indexing over a 16x32x16 area than one torch was calculating with no terminal output
11:42 oil_boi Holy crap there was so much debug output it stack overflowed dump()
11:53 sfan5 ūü§Ē
12:07 VanessaE joined #minetest
12:07 VanessaE joined #minetest
12:14 Eater4_ joined #minetest
12:29 panwolfram_ joined #minetest
12:29 est31 joined #minetest
12:29 superfly joined #minetest
12:29 Fixer joined #minetest
12:30 JTE joined #minetest
12:34 oil_boi sfan5, 0 lag https://i.imgur.com/wpu57SQ.png
12:34 oil_boi This is just insane
12:54 Vili_ joined #minetest
12:56 tuedel joined #minetest
13:08 kamdard joined #minetest
13:24 sknebel joined #minetest
13:48 ANAND joined #minetest
13:59 olliy joined #minetest
14:01 Taoki joined #minetest
14:09 sec^nd joined #minetest
14:20 SwissalpS joined #minetest
14:39 appguru joined #minetest
15:18 proller joined #minetest
15:23 FeXoR joined #minetest
15:24 Conradish006 joined #minetest
15:52 Itz-Noah joined #minetest
16:02 dvere joined #minetest
16:10 Pie-jacker875 joined #minetest
16:27 Conradish006 joined #minetest
16:50 Itz-Noah joined #minetest
16:50 Itz-Noah joined #minetest
16:55 ItzNoah joined #minetest
16:55 ItzNoah joined #minetest
16:58 appguru joined #minetest
17:02 Pie-jacker875 joined #minetest
17:19 loggingbot_ joined #minetest
17:19 Topic for #minetest is now The official Minetest channel | Latest version: 5.2.0 (2020-04-05) | General, player and modder discussion is on-topic. If in doubt, post here | Responses may take a while, be patient | Rules: https://wiki.minetest.net/IRC#Rules | Development: #minetest-dev | Server list: https://minetest.net/servers | IRC logs: http://irc.minetest.net/minetest
17:19 bwarden joined #minetest
17:19 nashimus joined #minetest
17:19 TGS joined #minetest
17:19 TGS joined #minetest
17:20 Xorkle joined #minetest
17:28 TGS joined #minetest
17:28 TGS joined #minetest
17:29 SwissalpS joined #minetest
17:29 tnewman joined #minetest
17:29 sagax joined #minetest
17:29 cheapie joined #minetest
17:29 NathanS21 joined #minetest
17:29 xSmurf joined #minetest
17:29 ssieb joined #minetest
17:29 frostsnow joined #minetest
17:29 BuckarooBanzai joined #minetest
17:33 AndDT joined #minetest
17:36 Conradish006 joined #minetest
17:51 fluxflux joined #minetest
17:57 Pie-jacker875 joined #minetest
18:32 Corey[m]1 has anyone every attempted to remove 'default' from their mod's depedency before, it's like a horror experience, when you realize how many little spots it exists in
18:35 rubenwardy I hate default
18:35 eerungur left #minetest
18:38 Corey[m]1 I'll let you know how badly it goes shortly, I need to replace the sounds first...
18:43 Wuzzy joined #minetest
18:43 MinetestBot Wuzzy: Jun-30 03:41 UTC <oil_boi> I think it's almost time you can put redstone into mc2
18:43 MinetestBot Wuzzy: Jun-30 03:41 UTC <oil_boi> referring to "how feasible would it be to cannibalize this and put it into mc2?" in the forum a few months ago
18:50 awell joined #minetest
18:50 Hawk777 joined #minetest
19:02 Corey[m]1 um... why is LIGHT_MAX in default, isn't that more of an engine thing?
19:02 Verticen joined #minetest
19:04 oil_boi Why yes, I have tried to remove default from my mod dependencies
19:05 oil_boi I dunno why that made me laugh so hard
19:06 rubenwardy it's an alias to not break mods, Corey[m]1
19:06 rubenwardy it is also in the engine
19:06 Corey[m]1 Well I have the source of everything on hand, so I can always verify, core does indeed have LIGHT_MAX
19:06 Corey[m]1 but from what I gather, we shouldn't ever be referencing core. in mods
19:07 rubenwardy minetest.LIGHT_MAX
19:07 rubenwardy default has the following line:    `default.LIGHT_MAX = minetest.LIGHT_MAX`
19:07 rubenwardy and minetest builtin has the following line:  `minetest = core`
19:07 Corey[m]1 strange, the copy I have here says `default.LIGHT_MAX = 14` not the minetest reference
19:07 rubenwardy oh, that's silly
19:08 Corey[m]1 mods/default/init.lua
19:08 Corey[m]1 12:default.LIGHT_MAX = 14
19:08 Corey[m]1 yep
19:21 ItzNoah joined #minetest
19:21 ItzNoah joined #minetest
19:29 Zughy joined #minetest
19:38 Fuchs_ joined #minetest
19:41 Fuchs joined #minetest
19:47 Quiark joined #minetest
19:47 riff-IRC joined #minetest
19:48 Lone_Wolf joined #minetest
19:48 search_social Hi, I just git cloned the latest worldedit and am getting this error on //1: worldedit.marker1[name]:get_luaentity()
19:48 search_social is nil
19:48 jfred[m]1 joined #minetest
19:48 indiana joined #minetest
19:49 search_social 2020-06-21 21:03:54: ERROR[Main]: ServerError: AsyncErr: ServerThread::run Lua: Runtime error from mod 'worldedit_commands' in callback item_OnUse(): ...52.git/bin/../mods/worldedit/worldedit_commands/mark.lua:23: attempt to index a nil value
19:49 Zughy 970 issues, ouch
19:49 search_social 2020-06-21 21:03:54: ERROR[Main]: stack traceback:
19:49 search_social 2020-06-21 21:03:54: ERROR[Main]:       ...52.git/bin/../mods/worldedit/worldedit_commands/mark.lua:23: in function 'mark_pos1'
19:49 search_social 2020-06-21 21:03:54: ERROR[Main]:       ...52.git/bin/../mods/worldedit/worldedit_commands/wand.lua:23: in function <...52.git/bin/../mods/worldedit/worldedit_commands/wand.lua:17>
19:49 IsmaelOlea[m] joined #minetest
19:49 sfan5 uh
19:49 sfan5 maybe use a pastebin for the error message next time
19:49 search_social sorry
19:51 oil_boi yes and add emojis to it
19:51 sfan5 unless the entity mysteriously disappears I don't see how that error could happen
19:51 sfan5 is it reproducible?
19:52 search_social yes it happens anytime i use //1 .. i'm wondering if it's because of old data from the previous worldedit
19:52 oil_boi Why not add if not thing:get_luaentity() return end
19:52 sfan5 old data?
19:52 Krock oil_boi: "marker1[name]" is nil, not the value of get_luaentity
19:53 search_social i guess it could be some other mod like regional climate doing something
19:53 oil_boi Wait no that's recursive problem if not thing[table] or (thing[table] and not thing[table]:get_luaentity()) then return end
19:53 sfan5 Krock: the error message doesn't indicate that does it?
19:53 oil_boi It does
19:53 search_social i verified with print statements that worldedit.marker1[name] = userdata: 0x42ac4f00
19:54 oil_boi Are you exceeding the loaded area/area unloading despawning entity?
19:54 search_social well the server just started after the last crash and i haven't issued any command except //1
19:54 oil_boi Ah yes a table index check and table index if luaentity check would stop that from crashing
19:55 sfan5 search_social: add some debug output for  orldedit.marker1[name]:get_luaentity() please
19:55 oil_boi But might cause undefined behavior
19:55 Krock sfan5: I don't know about "//1" but "//1: worldedit.marker1[name]:get_luaentity()" looked to me like the code that caused the error later on
19:56 search_social sfan5: well i tried print(type(worldedit.marker1[name]:get_luaentity()) and it said mark.lua:36: bad argument #1 to 'type' (value expected)
19:56 ShadowBot https://github.com/minetest/minetest/issues/1 -- GlowStone code by anonymousAwesome
19:56 Krock since 5.3.0-dev there's no undefined entity behaviour
19:56 search_social oh yeah i'm running 5.2.0 so i need to run 5.3.0?
19:56 Krock it's a bug when using the latest stable, so I suppose it should be fixed somehow, even if it works in 5.3.0-dev
19:56 sfan5 search_social: type(nil) is valid so no idea about that
19:57 oil_boi undefined behavior in the calculations that are stated between these two entities hm hm hm hm
19:57 sfan5 I haven't heard any reports that worldedit is broken in 5.2 either
19:57 oil_boi aka crashing boi
19:57 Krock > if (co == NULL) return 0;
19:57 Krock 0 returned arguments when the objcet cannot be found
19:57 Krock though that should return "nil"? dunno
19:58 sfan5 so return 0; isn't equivalent to returning nil after all?
19:58 sfan5 search_social: try print(type((worldedit.marker1[name]:get_luaentity())))
19:58 sfan5 with exactly those parenthesis
19:58 Krock I mean there's lua_isnone  but I don't know when this applies
19:58 oil_boi Could the table be creating the data before it's instated into the core.registered_entities on a really slow computer?
19:59 sfan5 no it all happens sequentially on a single thread
19:59 oil_boi Then I'll be ducked, gotta add an exception to the code incase of failure of creation lua entity/instant deletion/something destroying table data randomly
20:00 sfan5 the weird thing is that the entity reference is being created correctly but the reference is invalid
20:00 sfan5 could be a 5.2 specific bug after all
20:00 oil_boi Why not base the positional data off an internal memory map as to not rely on something that could possibly despawn and handle between those two points regardless of the entity existing?
20:01 search_social (worldedit.marker1[name]:get_luaentity()) --- print(type()) this is nil and print() this is nil too
20:01 sfan5 that's what it does, the entities are just for display
20:02 oil_boi I dunno then man just make the position explode if the entity isn't found
20:04 sfan5 search_social: which mods are you running?
20:06 search_social a lot of ones from content db the one that seemed most likely to cnoflict was something was the regional weather one
20:06 search_social the old worldedit mod that wasn't crashing i see the mark function doesn't have a "region_too" paramater
20:07 search_social or an "init_sentinel"
20:08 sfan5 well idk
20:08 sfan5 you can comment out call code inside on_active (3 functions total) and it should work
20:08 sfan5 on_activate*
20:11 search_social okay that made it work thanks!!!!!
20:14 Lone_Wolf joined #minetest
20:24 calcul0n joined #minetest
20:37 Flabb joined #minetest
20:38 oil_boi I did not expect that solution
20:39 guzzi joined #minetest
20:45 bruce joined #minetest
20:45 Guest53785 Hello
20:49 Guest53785 My minetest can't fetch content DB and server list
20:49 rubenwardy OS?
20:49 Guest53785 Linux mint
20:50 Guest53785 Linux Mint 19.3
20:51 Guest53785 The terminal output this:
20:51 Guest53785 2020-07-01 17:50:46: ERROR[Main]: https://content.minetest.net/api/packages/?type=mod&amp;type=game&amp;type=txp&amp;protocol_version=39&amp;hide=nonfree&amp;hide=desktop_default not found (Timeout was reached) (response code 0)
20:51 Guest53785 but when I put this url in firefox browser I cant get the json perfectly
20:53 rubenwardy you can try increasing the curl timeout, but it should already be at 30 seconds
20:54 rubenwardy what happens if you try again? It might be cached now
20:54 Guest53785 The same happens
20:54 Guest53785 I'll try to increase timeout
20:57 Guest53785 This is my config: https://imgur.com/SAdflg5
20:59 Guest53785 Men, it's works!
20:59 rubenwardy what timeout did you need?
20:59 Guest53785 I just increase timeout
20:59 Guest53785 30 000
20:59 rubenwardy I'm surprised it takes longer than 30 seconds
21:00 Guest53785 My network has currently 3Mbps
21:02 Guest53785 Thanks
21:09 Guest53785 How can I help improve minetest menu. I've some programming knowledge
21:10 rubenwardy at this point, we're waiting on UX design
21:10 Itz-Noah joined #minetest
21:10 Itz-Noah joined #minetest
21:12 rubenwardy see https://github.com/minetest/minetest/issues/6733
21:13 Guest53785 I've already see this issue and would like to implement tacotexmex menu
21:14 rubenwardy see my comment there
21:16 Guest53785 Great, I see
21:17 rubenwardy I suppose you could merge the two designs, with a new GUI system
21:17 rubenwardy just merging designs probably won't work well
21:18 Guest53785 So what I do?
21:32 Guest53785 Did you know a youtube channel that have good minetest survival videos?
21:34 rubenwardy I don't, but here's a topic with videos: https://forum.minetest.net/viewtopic.php?f=3&amp;t=8499
21:34 rubenwardy also checkout   https://www.youtube.com/user/313hummer/videos
21:38 hisforever joined #minetest
21:39 gry joined #minetest
21:41 hisforever Hi I just reinstalled Manjaro Linux os on Laptop. I installed minetest. In Home folder there is No .minetest folder. Should I put the .mintest in my home Folder so I can put my mod folder there ?
21:42 Guest53785 Did you started minetest for the first time?
21:42 Guest53785 When you create a world the .minetest should be created, I think
21:43 Guest53785 If not created
21:43 hisforever yes I actually have installed Mods in minetest itself
21:43 hisforever I thought that myself
21:44 Guest53785 How do you install minetest?
21:44 Guest53785 Did you use flatpak?
21:44 appguru joined #minetest
21:44 hisforever through terminal with sudo pacman -S minetest
21:45 hisforever I think it was throught
21:45 hisforever flat pack
21:46 hisforever I'll just unstall minetest then reinstall
21:46 hisforever brb
21:46 admicos pacman is the native package manager of arch-based distros, flatpak is a seperate thing
21:47 admicos just letting you know
21:47 rubenwardy if you run minetest at least once, it'll create ~/.minetest
21:47 rubenwardy you may need to create a world or something first
21:47 rubenwardy note that the dot means it is hidden
21:47 hisforever yes I know that, thats why I'm unstalling then reinstalling
21:48 hisforever I also know that .minetest is hidden
21:48 hisforever brb
21:50 Lone_Wolf @Guest53785, there are a few streamers on Twitch too
21:50 rubenwardy hm
21:51 erlehmann joined #minetest
21:52 Guest53785 Open a new terminal and type "ls ~/.minetest"
21:52 Guest53785 What is the output?
21:53 Guest53785 Type without the commas
21:55 fluxflux joined #minetest
21:56 hisforever ok I just installed mt 5.2.0 and everything looks great thanks for the help
21:56 Zughy hisforever: can't you just install it via the official application manager? I have Minetest on a Manjaro too and it perfectly works
21:56 Zughy oh, too late
21:57 hisforever Zughy thats the way I did it this time
21:58 hisforever lol
21:59 hisforever ok your a great bunch thanks again see you soon
22:03 galex-713 joined #minetest
22:12 Zughy does this work for human beings too?
22:12 Zughy !next
22:12 MinetestBot Another satisfied customer. Next!
22:12 Zughy YES (*normal human beings)
22:22 Lone_Wolf joined #minetest
22:22 bruce joined #minetest
22:41 bruce_ joined #minetest
22:48 Zughy so hey guys, how's going with the 5.3?
22:53 sfan5 left issues: https://github.com/minetest/minetest/milestone/16
23:05 Zughy it was more some sort of "tell me about it", with people crying, screaming, walking on the ceiling and such
23:06 sfan5 well #10113 is potentially a huge issue or maybe not an issue at all
23:06 ShadowBot https://github.com/minetest/minetest/issues/10113 -- Severe performance degradation in 5.3 compared to 5.2
23:06 sfan5 but nobody really knows
23:06 sfan5 and I can't be bothered to try this out either
23:09 Zughy yeah, that doesn't seem funny at all to track down
23:10 Morphyx joined #minetest
23:11 Morphyx Hi
23:12 Zughy heyo
23:13 Morphyx I was borred and come to talk a bit
23:19 Tommasso joined #minetest
23:29 appguru going through https://github.com/minetest/minetest/pulls?q=is%3Apr+is%3Aclosed+performance rn
23:41 Corey[m]1 There are texture packs, but, are there sound packs for minetest?

| Channels | #minetest index | Today | | Google Search | Plaintext