Minetest logo

IRC log for #minetest, 2018-01-31

| Channels | #minetest index | Today | | Google Search | Plaintext

All times shown according to UTC.

Time Nick Message
00:21 nowhereman_ joined #minetest
00:22 twoelk|2 joined #minetest
00:25 Copenhagen_Bram joined #minetest
00:29 EvergreenTree joined #minetest
00:49 stormchaser3000 joined #minetest
01:01 Copenhagen_Bram joined #minetest
01:11 proller joined #minetest
01:13 progysm highlander!
01:14 Copenhagen_Bram joined #minetest
01:19 EvergreenTree joined #minetest
01:21 jin_xi joined #minetest
01:32 ThomasMonroe joined #minetest
01:40 catwhisperer777 joined #minetest
01:47 ThomasMonroe joined #minetest
01:48 Taoki joined #minetest
01:49 twoelk left #minetest
01:51 Copenhagen_Bram joined #minetest
01:52 turtleman joined #minetest
02:06 whitephoenix joined #minetest
02:11 Copenhagen_Bram joined #minetest
02:17 catwhisperer777 joined #minetest
02:17 adfeno left #minetest
02:23 nowhere_man joined #minetest
02:26 Copenhagen_Bram joined #minetest
02:30 Miner12 left #minetest
02:35 Copenhagen_Bram joined #minetest
02:42 Tmanyo joined #minetest
02:46 Copenhagen_Bram joined #minetest
03:28 Copenhagen_Bram joined #minetest
03:29 AndroBuilder joined #minetest
03:43 Billr joined #minetest
04:10 catwhisperer777 joined #minetest
04:11 Billr good
04:11 Billr unkbot: status
04:43 catwhisperer777 joined #minetest
04:44 catwhisperer777 joined #minetest
04:45 catwhisperer777 joined #minetest
04:45 catwhisperer777 joined #minetest
04:46 catwhisperer777 joined #minetest
04:48 Copenhagen_Bram joined #minetest
05:06 catwhisperer777 joined #minetest
05:11 Billr joined #minetest
05:12 Billre joined #minetest
05:14 Darcidride joined #minetest
05:14 whitephoenix joined #minetest
05:16 Copenhagen_Bram joined #minetest
05:20 catwhisperer777_ joined #minetest
05:20 est31 joined #minetest
05:33 Pie-jacker875 joined #minetest
05:33 Void7 joined #minetest
05:34 Copenhagen_Bram joined #minetest
05:52 ChadMcNugget joined #minetest
05:56 Copenhagen_Bram joined #minetest
06:04 Billr joined #minetest
06:09 Billre joined #minetest
06:32 LazyJ joined #minetest
06:42 Copenhagen_Bram joined #minetest
06:47 torgdor joined #minetest
07:06 Hawk777 joined #minetest
07:24 whitephoenix joined #minetest
07:28 aheinecke joined #minetest
07:49 Emerald2 joined #minetest
07:49 Emerald2 joined #minetest
07:52 Darcidride_ joined #minetest
07:57 jluc joined #minetest
08:07 Markow joined #minetest
08:08 CWz joined #minetest
08:26 vergilzen joined #minetest
08:27 pandaro joined #minetest
08:36 ensonic joined #minetest
08:37 MaybeDragon joined #minetest
08:39 Darcidride joined #minetest
08:49 jin_xi joined #minetest
08:54 Pie-jacker875 joined #minetest
09:03 nac joined #minetest
09:26 Lukc- joined #minetest
10:03 vergilzen joined #minetest
10:27 Billr joined #minetest
10:29 Beton joined #minetest
10:32 troller joined #minetest
10:47 anonny joined #minetest
10:47 anonny hi
10:48 YuGiOhJCJ joined #minetest
11:21 Pie-jacker875 joined #minetest
11:23 redblade7 joined #minetest
11:59 ensonic joined #minetest
12:24 xSmurf joined #minetest
12:30 lumberJ joined #minetest
12:44 Fixer joined #minetest
13:10 Surfer_ joined #minetest
13:10 Surfer_ hello
13:10 Surfer_ if i use the minetest.conf in my server ... will those settings overwrite my client settings?
13:10 sfan5 no
13:11 Surfer_ so key-control settings in the server conf don#
13:11 Surfer_ don't make any sense since they will be overwritten by the client settings
13:12 Surfer_ f.e. changing inventory to "e" instead of "i"
13:17 xSmurf joined #minetest
13:18 sfan5 yes
13:18 sfan5 the server does not send any settings to the client anyway
13:20 rubenwardy worth noting that singleplayer uses the same config for server and client without corruption
13:26 KrimZon_2 joined #minetest
13:32 ThomasMonroe joined #minetest
13:38 Surfer_ is there any other place my static spawn point could be set? because i changed it but joining with new players they will spawn at the old point
13:39 Surfer_ i set it in the minetest.conf of the server
13:40 ThomasMonroe if you sleep in a bed I believe it sets the spawn point there
13:40 Surfer_ but just my personal one
13:41 ThomasMonroe yeah, your personal one
13:42 Surfer_ i'm looking for the place to set the global spawnpoint for new players? (in minetest.conf - on the server it won't take any affect)
13:56 sfan5 static_spawnpoint = 11, 22, 33
13:56 sfan5 in the server .conf obviously
14:00 Surfer_ got it ... don't know why the server didn't work the first time
14:00 Surfer_ mods/interact/init.lua:55: in function 'make_formspec4' (Main Error) ...
14:03 Tux[Qyou] joined #minetest
14:05 Peppy joined #minetest
14:10 Pie-jacker875 joined #minetest
14:24 nowhereman_ joined #minetest
14:28 Billr joined #minetest
14:35 Surfer_ sfan5: can't find where to set a server password :(
14:35 progysm a server password?
14:38 Surfer_ yes? to connect to the server? thought i read this is possible for "first login"
14:55 progysm there is a name = playername  setting in minetest.conf
14:55 progysm for the admin account
14:56 progysm so you set name = Surfer in the conf, then you login with the username Surfer and you set your password. You are now admin.
14:57 Billr joined #minetest
14:57 nac joined #minetest
15:02 troller joined #minetest
15:20 Billr joined #minetest
15:21 antims joined #minetest
15:29 ThomasMonroe joined #minetest
15:37 ThomasMonroe joined #minetest
15:43 ensonic joined #minetest
15:44 Markow joined #minetest
15:47 Wuzzy joined #minetest
15:56 Fixer joined #minetest
15:58 ThomasMonroe joined #minetest
16:04 nac joined #minetest
16:15 troller joined #minetest
16:16 LevierMRQ joined #minetest
16:18 whitephoenix joined #minetest
16:32 Akberid joined #minetest
16:57 vergilzen joined #minetest
16:59 LevierMRQ joined #minetest
17:07 ensonic joined #minetest
17:08 LevierMRQ joined #minetest
17:16 est31 joined #minetest
17:30 Darcidride_ joined #minetest
17:47 Krock joined #minetest
17:51 lumberJ joined #minetest
17:54 Telesight joined #minetest
17:55 Jordach joined #minetest
17:55 Pie-jacker875 joined #minetest
18:08 troller joined #minetest
18:11 Enricoo joined #minetest
18:17 Billr joined #minetest
18:19 anonny joined #minetest
18:19 anonny hi
18:20 anonny left #minetest
18:26 Krock bai
18:27 Gael-de-Sailly joined #minetest
18:30 redblade joined #minetest
18:37 ensonic joined #minetest
18:38 octacian joined #minetest
18:47 Enricoo joined #minetest
18:59 xavierg joined #minetest
18:59 xavierg Hi
18:59 redblade7 hi
19:00 Gael-de-Sailly hi
19:01 xavierg I am a casual Minetest player; a few minutes ago, I reopened my old world (should be able to get a timestamp...) using minetest 0.4.16+repack-4 (as found in Debian Sid)... and it looks like my viewpoint is stuck.
19:01 xavierg my character keeps lookin all the way up
19:01 xavierg moving the mouse only seems to circle very fast around that point
19:02 xavierg Does that behaviour ring a bell to anyone ?
19:04 Fixer xavierg: are you under wayland? or xorg
19:04 xavierg X.org
19:06 Fixer try restarting the game, wonder what is your DE/WM
19:06 xavierg I did try that of course, but the behaviour persists; my DE is LxQt, my WM is OpenBox.
19:07 xavierg I tried to google the issue a little but found nothing relevant.
19:08 xavierg I am going to try to spawn a new world
19:08 xavierg same behaviour
19:08 xavierg I am going to put ~/.minetest aside.
19:09 Fixer we had something like that with xwayland, but not with xorg
19:09 Fixer xavierg: you should probably open a bugreport here https://github.com/minetest/minetest/issues
19:09 Billr joined #minetest
19:10 xavierg same behaviour again
19:10 xavierg Fixer: ok, I will
19:11 Krock a DPI issue with Irrlicht?
19:12 Fixer i've search github and did not find anything similar apart from xwayland spinning
19:13 xavierg https://github.com/minetest/minetest/issues/4629 -- this sounds close
19:16 xavierg adding mouse_sensitivity = 0.005 in minetest.conf makes the spinning much slower but I am still spinning around the z-axis
19:19 nowhere_man joined #minetest
19:24 Billr joined #minetest
19:24 xavierg I observe the same behaviour using 0.4.15+repack2-1 in a stretch/stable container.
19:24 xavierg So that must indeed be related to my WM.
19:25 jin_xi joined #minetest
19:25 xavierg Oh.. when I click
19:26 xavierg I can see my cursor becoming a resizing cursor for half a second
19:28 pgimeno_ does it properly free your mouse when you press esc? where does the mouse appear if so?
19:30 xavierg when I press escape, the mouse appears first at the centre of the Minetest window, right on the "Change keys" button but the very first movement makes it jump somewhere else (here, roughly +800 +600) before it behaves normally.
19:31 pgimeno_ hmm, that's weird and probably related
19:31 Fixer xavierg: can you try with fullscreen = true ?
19:31 xavierg I really feel like I have the exact same issue as "hoosierEE" on #4629
19:32 Fixer probably
19:33 xavierg Fixer: fullscreen = true is ignored, minetest starts in windowed mode
19:33 Beton joined #minetest
19:36 Fixer xavierg: wonder what is your irrlicht version
19:38 Fixer xavierg: can you look it up?
19:41 xavierg 1.8.4+dfsg1-1 for both the stretch/stable container and my Sid system.
19:41 Fixer xavierg: ty, i've posted this info in that issue
19:42 Fixer xavierg: what is your monitor resolution, btw?
19:42 xavierg 1920x1200+1920x1080
19:42 Fixer double monitor setup?
19:42 xavierg yep
19:43 Fixer interesting, will note this in issue
19:43 xavierg I wonder if it happens on my laptop...
19:43 Fixer xavierg: and minetest is running on what? does it occur in both?
19:43 Fixer on both monitors?
19:43 xavierg it happened on both, yes
19:45 xavierg Fixer: interestingly, it works fine on my laptop, which has the same setup: LxQt+OpenBox
19:45 Fixer xavierg: same OS?
19:46 xavierg Yep, Debian Sid too.
19:47 xavierg That means that *something* specific to my workstation is triggering the issue.
19:47 Fixer yeah, wonder what are your videocards in both cases?
19:47 xavierg nvidia with nouveau driver on the laptop, AMD/ATI with radeon driver on the workstation... I doubt it matters though
19:49 Fixer i hope developers will look into that eventually, you may try to tinker with different settings
19:49 Billre joined #minetest
19:50 xavierg I will investigate further, yes, as I am very curious as to what triggers the issue on my workstation but not on my laptop
19:50 MinetestBot [git] TumeniNodes -> minetest/minetest_game: Add obsidian_pane (#2035) b775a5e https://git.io/vN5oT (2018-01-31T19:49:54Z)
19:50 MinetestBot [git] Jat15 -> minetest/minetest_game: Stairs: unbind table groups (#2036) 5f121b5 https://git.io/vN5ok (2018-01-31T19:49:27Z)
19:50 troller joined #minetest
19:53 xavierg Fixer: I have executed my workstation's minetest on my laptop's display over SSH+X11 and managed to get the bug on my laptop.
19:53 Fixer i'm not a dev, can't help beyond that
19:54 Fixer will paste that too
19:54 xavierg well, weird.... I cannot reproduce that
19:54 MinetestBot [git] TumeniNodes -> minetest/minetest_game: Add obsidian_pane (#2035) 496a1a2 https://git.io/vN5oK (2018-01-31T19:53:49Z)
19:54 xavierg I now get X Error of failed request:  XF86VidModeClientNotLocal ... which makes sense.
19:55 xavierg I have no idea how it worked the first time :D
19:55 Fixer i've added link to irc log, so they can read your postings
19:55 KrimZon_2 joined #minetest
19:56 xavierg nice :) I will report my investigations on the github issue if I can find anything relevant AND consistent
20:24 nowhereman_ joined #minetest
20:41 xavierg Fixer: this now happens to be specific to my user.
20:41 Fixer xavierg: aka unix user?
20:41 xavierg yep
20:42 xavierg Long story short, my workstation has a second user with very similar parameters; I tried minetest with that account and it worked fine.
20:43 Fixer thats odd
20:43 xavierg it is.
20:43 Fixer xavierg: if you have github account, please post that info in that issue
20:43 xavierg see 20:56:23 ;)
20:45 xavierg and when that user executes minetest on my display, I get the bug
20:48 xavierg it would be easy to blame openbox, but both users have the openbox config, byte for byte.
20:56 pgimeno_ xavierg: I was wondering if there's some kind of applet or the like that could be interfering with mouse capture
21:00 xavierg and if I do the opposite (executing my minetest on that user's display), my minetest works perfectly fine
21:00 xavierg pgimeno_: I was wondering that too but nothing hits me as an obvious culprit
21:00 troller joined #minetest
21:06 ThomasMonroe joined #minetest
21:08 Darcidride_ joined #minetest
21:10 ThomasMonroe joined #minetest
21:11 ThomasMonroe joined #minetest
21:14 thomasmonroe__ joined #minetest
21:15 thomasmonroe__ joined #minetest
21:19 ThomasMonroe joined #minetest
21:21 illwieckz joined #minetest
21:23 stormchaser3000 joined #minetest
21:25 nowhere_man joined #minetest
21:25 * xavierg has that weird feeling he is missing something obvious.
21:28 Billre left #minetest
21:31 Lunatrius joined #minetest
21:32 swift110 joined #minetest
21:39 xavierg What baffles me is that the LxQt+OpenBox configuration is the same on both X user sessions.
21:40 xavierg What could actually mess up focus and mouse input?
21:41 rubenwardy could be a rounding issue
21:41 rubenwardy are you able to compile?
21:41 xavierg Yes, I am.
21:41 xavierg But that binary works fine afaict.
21:41 rubenwardy you're currently on 0.4.16, right?
21:42 xavierg yep
21:43 xavierg The menu is not impacted by the problem btw.
21:59 lumberJ joined #minetest
21:59 xavierg I have to end my reflections here for today. To be continued...
22:00 rubenwardy https://gist.github.com/rubenwardy​/db188b7e53ea100d2aa27bc6efc8b8c8
22:00 rubenwardy xavierg ^
22:00 Jordach joined #minetest
22:02 xavierg rubenwardy: but how would that explain the issue happens only within *my* X user session?
22:02 rubenwardy no idea
22:02 rubenwardy I've had this report and I suspected it's due to weirdness in that area, never been able to reproduce though
22:03 stormchaser3000 joined #minetest
22:03 Billr joined #minetest
22:03 rubenwardy is it a different computer? hmm
22:04 xavierg nope
22:04 xavierg (forget about my laptop)
22:04 xavierg we're speaking of one minetest binary, two users, each with their minetest config (which differs).
22:05 xavierg both behaves the same way: when executed on the display of my X session, they spin around the Z-axis
22:05 xavierg when executed on the display of that other user's X session (which is very close to mine, config-wise), they behave fine.
22:06 xavierg that's why I am heading my research to something close to the window manager
22:06 xavierg behave*
22:07 troller joined #minetest
22:08 xavierg but I gotta go; maybe a good night of sleep will give some illumination :)
22:08 xavierg thanks to all of you for your support
22:13 * xavierg can't get this out of his head
22:14 xavierg If I resize the window using alt + right click, I can end up in a situation where I see the pointer moving far outside the minetest window while being constantly repositioned by minetest
22:15 xavierg This screams "window manager-induced window geometry issue". Maybe the window manager is not that innocent.
22:16 rubenwardy yeah, sounds like a WM problem
22:34 Pie-jacker875 joined #minetest
22:52 proller__ joined #minetest
22:56 rubenwardy left #minetest
23:05 ThomasMonroe joined #minetest
23:06 pgimeno_ xavierg: I wonder what happens when you resize the window in the user for which it works
23:08 pgimeno_ wonder if the different behaviours for the users might be explained with whether the window was ever resized or not
23:12 turtleman joined #minetest
23:17 nowhere_man joined #minetest
23:37 Taoki joined #minetest

| Channels | #minetest index | Today | | Google Search | Plaintext