Minetest logo

IRC log for #minetest-hub, 2018-01-11

| Channels | #minetest-hub index | Today | | Google Search | Plaintext

All times shown according to UTC.

Time Nick Message
00:08 sniper338 joined #minetest-hub
00:09 rubenwardy it's hard to ping him when he times out
00:09 EvergreenTree_ joined #minetest-hub
00:18 sniper338 joined #minetest-hub
00:23 celeron55 joined #minetest-hub
00:24 celeron55 oh well, the vps died and nothing brings it up; maybe the provider will answer at morning
00:31 celeron55_ joined #minetest-hub
00:34 red-001 retro much http://packages.8dromeda.net/minet​est/websites/minetest_oldsite.html ?
00:35 rubenwardy "The first stable version of Minetest 0.4 will be released as soon as the modding API is stable enough"
00:35 rubenwardy when's that gonna happen?
00:35 rubenwardy :troll:
00:35 red-001 also IRCnet
00:36 rubenwardy ha, "No sounds"
00:36 rubenwardy those were the days
00:36 red-001 http://packages.8dromeda.net/minetest/​websites/minetest_oldsite/0.4.php.html
00:37 rubenwardy "Development of the Minetest game continues with more freedom"
00:37 rubenwardy I wish
00:37 red-001 lol
01:04 Fixer rubenwardy: never
02:05 sniper570 joined #minetest-hub
02:13 EvergreenTree joined #minetest-hub
02:37 celeron55 that website was so joyful
02:51 paramat 5. Continue making more awesomeness. 6. ??? 7. Don't profit
02:57 EvergreenTree joined #minetest-hub
03:05 roben1430 joined #minetest-hub
03:36 paramat joined #minetest-hub
04:23 roben1430 joined #minetest-hub
05:30 compunerd joined #minetest-hub
06:15 nerzhul joined #minetest-hub
06:36 bwarden joined #minetest-hub
07:43 CWz joined #minetest-hub
09:17 redblade7 joined #minetest-hub
10:11 nerzhul joined #minetest-hub
11:19 IhrFussel joined #minetest-hub
11:20 IhrFussel Am I right when I say MT doesn't react to a ACPI shutdown? Or does it just not log the event?
11:20 Fixer joined #minetest-hub
11:21 IhrFussel My hoster sent an ACPI signal to my VM earlier and in debug.txt it looks like MT abruptly exited
11:23 IhrFussel 2018-01-11 09:53:09: ACTION[Server]: TRACKING MOB: MerleManga, Cinema Guard -> -8539,12,-6451
11:23 IhrFussel -------------  Separator
11:38 IhrFussel "admin pls mod im" << and such people still wonder why they get banned on many servers
11:38 shivajiva probably updating to mitigate the security threat
11:40 IhrFussel shivajiva, yes that was the reason...but my actual question is if MT just doesn't log a shutdown via ACPI or ignores such a signal
11:43 shivajiva I'd go for not aware but someone will correct me
11:45 IhrFussel AFAIK the init process will inform all other processes that the system is shutting down and wait until they finished ... the signal init sends should be a standard one cause lighttpd for example understood it too
12:02 sniper338 joined #minetest-hub
12:03 sniper338 joined #minetest-hub
12:04 Fixer IhrFussel: just mute those people
12:05 lisac joined #minetest-hub
12:29 behalebabo joined #minetest-hub
13:13 aerozoic joined #minetest-hub
13:25 Mr_Pardison joined #minetest-hub
13:29 Fixer joined #minetest-hub
13:47 tenplus1 joined #minetest-hub
13:47 tenplus1 hi folks
13:47 Mr-Pardison hi
13:47 tenplus1 hey mister :PP
13:49 Mr-Pardison or should I say hello fellow hooman....
13:49 tenplus1 ehehe :P
13:50 Fixer hi
13:50 Fixer zucc
13:50 tenplus1 o/ fixer
13:52 Wayward_One hi all :)
13:52 tenplus1 hi wayward
14:23 lumberJ joined #minetest-hub
14:23 tenplus1 hi lumber
14:24 lumberJ hey tenplus1
14:30 shivajiva Hi tenplus, didn't notice you sat there whilst I was bashing vbox about for the new kernel update :)
14:30 tenplus1 hi shiva :)
14:31 tenplus1 did the latest kernel update on my desktop today :) nvidia is fixed again :D
14:31 tenplus1 4.13.0-25 so far
14:31 shivajiva I ran around the block a few times till I realised I'd left gcc on 6
14:32 tenplus1 working ok now ?
14:32 shivajiva yea
14:32 shivajiva just needed to realise it couldn't compile using 6 on my sys
14:32 tenplus1 am very tempted to update to ubuntu 18.04 alpha 1 and see how it runs
14:33 shivajiva you like daily builds so why not try it
14:34 tenplus1 I did that with 17.10 and it was surprisingly rock stable... never an issue
14:35 shivajiva too much going on with my daily driver to take any risks :)
14:36 tenplus1 eek, what else is happening with it ?
14:38 shivajiva just in the sense I need access to various applications to do my work and downtime is costly.
14:38 tenplus1 ahh, gotcha
15:00 Fixer joined #minetest-hub
15:00 tenplus1 wb fixer
15:03 Fixer ty
15:16 rubenwardy oh noes
15:16 rubenwardy Github is down!
15:16 tenplus1 hi ruben... dont worry, it'll be up soon
15:17 rubenwardy so, votes to go back to using the old site?
15:17 tenplus1 old site ?
15:17 rubenwardy http://packages.8dromeda.net/minetest/​websites/minetest_oldsite/0.4.php.html
15:18 Mr-Pardison page gave me the unicorn thing.
15:18 rubenwardy the home page of that actually
15:18 rubenwardy http://packages.8dromeda.net/min​etest/websites/minetest_oldsite/
15:18 tenplus1 whassup with the new site ?
15:18 rubenwardy http://packages.8dromeda.net/minetest/w​ebsites/minetest_oldsite/index.php.html
15:18 Mr-Pardison I'm guessing it's a flood attack.
15:18 tenplus1 some idiot with a script
15:19 Fixer Unicorn
15:20 Fixer it is not unicorn only, but f.. wisdom tooth is going down
15:20 tenplus1 ??
15:21 Fixer it is dantist time, not really
15:21 Fixer i hope not this year
15:23 Fixer just when i wanted to post benchmark result, github told me to chill out
15:23 tenplus1 anything good ?
15:23 Fixer nuh
15:23 Fixer boring stuff
15:23 tenplus1 aw :P
15:23 rubenwardy fast faces?
15:24 Mr-Pardison And I was going to post my fork of woodcutter since I figured it wouldn't cause any interference with fast move using the aux1 key.
15:25 Fixer rubenwardy: yeajh
15:25 rubenwardy what was the result?
15:25 Fixer rubenwardy: on my setup, fps the same, and more cpu usage
15:25 rubenwardy cool
15:25 rubenwardy to be expected, given the removal of the cache
15:26 Fixer i measure in cpu cycles in process explorer
15:26 rubenwardy I imagine there would be more jitter to, due to loss of cache
15:26 rubenwardy also, worth experimenting on a world which is constantly regenerating meshes
15:26 tenplus1 wait, is that what the spectre fix does ? remove cache usage ?
15:26 rubenwardy tenplus1: talking about MT lol
15:27 rubenwardy the spectre fix adds more checking to page tables, iirc. Nothing to do with caches
15:27 IhrFussel joined #minetest-hub
15:27 rubenwardy actually, I haven't looked into it yet
15:27 tenplus1 hi fussel
15:27 Fixer i've looked at stand deviation as measure of fps jitter, it was mostly the same as before
15:27 IhrFussel I just updated my local PC with the KPTI patch ... is it just me or does MT run slower now?
15:28 Fixer rubenwardy: ~14% more cpu cycles
15:28 IhrFussel At least client side I notice a pretty big impact when rendering meshes
15:28 Fixer IhrFussel: i did a emergeblocks benchmark recently, was like 15% slower, not sure if KPTI is a cause
15:29 Fixer IhrFussel: rendering should not be affected by KPTI much, benchmarks I've seen gave little difference
15:29 rubenwardy just need the forum to go down, then I'll have to do work!
15:29 Fixer IhrFussel: i have data on my benchmarks, fps is pretty much the same before/after patch
15:29 IhrFussel But I'm using the exact same settings, same view range etc and suddenly get LOTS of slowdowns around my server spawn area
15:30 * tenplus1 shakes fist at Intel
15:30 Fixer fps in minetest is not affect by KPTI, my benchmarks confirm
15:31 Fixer i tested minetest on December 31 and today
15:31 Fixer same avg fps, min, max
15:32 Fixer rubenwardy: i've tested on ancient OGL 2.1 card with 256mb ram though
15:33 Fixer rubenwardy: so whats the catch with fast faces, whats the problem with it?
15:33 rubenwardy no idea
15:33 rubenwardy I've not investigate that area
15:34 rubenwardy basically anything render related is a nope from me
15:36 Fixer IhrFussel: maybe someone build and enabled something with particles near your spawn
15:36 Fixer IhrFussel: like faucet
15:36 tenplus1 could be, any changes in entity or nodebox faces or particles would affect area
15:37 IhrFussel I'm checking that right now, there may be some moretrees trees nearby now which could cause some slowdown
15:37 tenplus1 that's why I have a sky platform 1000 nodes up to test things like that... always same
15:37 rubenwardy particles suck
15:37 Mr-Pardison github is back up
15:37 Fixer uuup
15:38 Fixer and that particles PR still not merged/wip
15:39 rubenwardy yeah, it has issues
15:39 IhrFussel Why are moretrees leaves so resource intensive by the way? Special drawtype?
15:40 rubenwardy lots of see-through leaves
15:40 Mr-Pardison So, now that I have a fork of the woodcutting mod, should I commit the changes to the master or put it in a branch & start a PR?
15:41 tenplus1 a PR to the original ?
15:42 rubenwardy also, spawning trees
15:42 Mr-Pardison I made a fork of it since mine changes the init to use aux1 instead of sneak
15:42 tenplus1 ahh, if that's the only change and it works better then a PR to the original is a good idea
15:43 Mr-Pardison ty.
15:43 IhrFussel Fixer, inventory management feels slower though... WHAT from 60 FPS to 18 when I press I
15:44 tenplus1 isnt that a feature ?
15:44 tenplus1 you can set inventory fps in .conf
15:44 Fixer IhrFussel: interesting, I had the same bug once, looks like it needs to be reported
15:44 Fixer IhrFussel: try restarting minetest, it should go away
15:45 IhrFussel And 250% dtime_jitter ... will try thanks
15:47 IhrFussel Didn't fix it... it cannot be caused by UI can it?? I mean why would the client need that much resources to load 80 inventory images?
15:49 tenplus1 are you talking about when you open inventory the FPS drops ???  pause_fps_max = 20   handles that
15:50 IhrFussel Inventory is pausing? Sounds very misleading
15:50 tenplus1 yeah...
15:50 tenplus1 if you are concentrating on inventory then fps isnt all that important :PPP
15:51 IhrFussel tenplus1, the problem is that I dn't see fast enough where I drag and drop my items... it's constantly stuttering
15:51 tenplus1 change pause_fps_max to 30
15:51 tenplus1 might help
15:57 IhrFussel Which dev thought that pause FPS should apply to the inventory?
15:57 tenplus1 did upping the value help ?
15:57 IhrFussel Those are totally different... I will try now one sec
16:00 IhrFussel tenplus1, unless I have to re-open my client after changing it in advanced settings, nope that's not the fix
16:00 tenplus1 worth a try :P
16:02 IhrFussel Nope, Esc goes down to 30 but inventory still decreases to ~ 18 ... the chat console ecreases the FPS to 45 by the way
16:02 tenplus1 that's weird indeed...
16:04 IhrFussel I don't believe that the inventory is resource hungrier than the map ... even inside a city with many buildings I get at least 30 FPS
16:04 tenplus1 I wonder if itthe redraw of the inventory over the top of the map that has an issue
16:04 tenplus1 slowdown somewhere
16:05 IhrFussel Does the client load all inventory page contents at once? That could maybe explain it (1,800 nodes)
16:05 rubenwardy no
16:05 Fixer tenplus1: opening inventory does not lower fps usually
16:05 rubenwardy it's on demand
16:05 Fixer it is a bug
16:06 Fixer IhrFussel: can you open a bugreport? i will confirm it too
16:06 tenplus1 good to know fixer, that's what I was getting at
16:07 IhrFussel Fixer, the question is if it only affects UI or the default inventory too
16:09 Fixer IhrFussel: default inventory too
16:09 Fixer IhrFussel: chest formspec and greative inventory iirc
16:12 tenplus1 huge drop
16:14 Fixer IhrFussel: yeah, I had the same thing on default creative inventory, even reported on irc
16:16 Fixer IhrFussel: http://irc.minetest.net/minet​est-dev/2017-12-16#i_5170114
16:17 Fixer IhrFussel: can you create a bugreport? i'm lazy, i will confirm and try reproduce again
16:20 IhrFussel I will test in singleplayer first...in 0.4.16, 0.4.17 and 0.5.0-dev
16:21 Fixer IhrFussel: i had it in 0.5.0-dev mid december build I believe
16:22 Fixer IhrFussel: start in creative mode
16:23 IhrFussel 0.4.16 sfinv FPS only drop a lot when in one of the nodes tab, not when in craft mode
16:24 IhrFussel I mean craft grid drops FPS less ... nodes tab -> 22 FPS, craft grid -> 36 FPS
16:25 IhrFussel Very interesting... craft grid stays at 55-60 FPS in 0.4.17, nodes tab still decreases FPS 27
16:26 tenplus1 I wonder if it has anything to do with animated items
16:26 Fixer i don't have anything animated
16:27 tenplus1 see what the fps is when showing a normal formspec without inventory
16:27 IhrFussel 0.5.0-dev sfinv in craft grid: 37 FPS, nodes tab: 23 FPS
16:28 IhrFussel For some reason 0.4.17 improved it
16:29 IhrFussel But 0.5.0-dev made it worse again??
16:32 Fixer IhrFussel: it is random, sometimes bug does not kick in right away, something is triggering it
16:33 IhrFussel I'm asking other players on my server right now...they report the same drops...one says without inventory 42 FPS with inventory 23 FPS
16:34 IhrFussel By the way for some reason the default window size in 0.4.17 backports is pretty small
16:36 IhrFussel Only in 0.4.17, 0.4.16 and 0.5.0-dev have the regular window size ... Fixer I'll test some more and open a bug report later if nobody did until then
16:43 IhrFussel tenplus1, a regular formspec with just text doesn't decrease the FPS at all... 59-60
16:44 tenplus1 so it has to do with drawing the inventory slots
16:46 IhrFussel Most likely... and the drop in FPS is less in sfinv vs UI cause sfinv displays less nodes at once (24 vs 80)
16:47 IhrFussel I hope MT doesn't accidentally render the inventory images as 3D internally or something like that
16:48 tenplus1 I think it does now
16:48 tenplus1 was changed for 3dcube inv items
16:48 tenplus1 was gonna suggest adding this to .conf and testing again: inventory_items_animations = false
16:49 IhrFussel The animations are off by default I think, but maybe that setting causes some effect..let me try
16:49 tenplus1 yeahm, thinking the same
16:50 tenplus1 maybe redraws items unless it's specifically false and not nil, who knows
16:52 Fixer IhrFussel: yeah, probably smth about inv drawing
16:53 Fixer this is probably a new bug, i've noticed it by increased mouse lag, and then looked at fps...
16:54 IhrFussel It exists since Jul 19 at least (commit of my 0.4.16 client)
16:54 IhrFussel 2017*
16:54 Fixer https://www.youtube.com/watch?v=nzWF9A1vBSg little music offtopic
16:55 tenplus1 :P
16:57 Fixer 2010, that was like yesterday
16:58 tenplus1 lol, the years go by sooooooo fast :P
17:07 tenplus1 laters all o/
17:08 tenplus1 left #minetest-hub
17:22 Krock joined #minetest-hub
17:36 ircSparky joined #minetest-hub
17:42 Darcidride_ joined #minetest-hub
17:57 lumberJ joined #minetest-hub
17:57 EvergreenTree joined #minetest-hub
18:14 IhrFussel https://github.com/minetest/minetest/issues/6905
18:16 red-001 #6905
18:16 ShadowBot https://github.com/minetest/minetest/issues/6905 -- FPS in inventories drop drastically if the inventory displays a page with items
18:32 Fixer IhrFussel: ty
18:36 Mr_Pardison joined #minetest-hub
18:42 Fixer IhrFussel: post your OS and config (excluding private info ofc)
18:43 Krock IhrFussel, did you check whether it's not the pause fps setting that could be implemented wrongly?
18:44 Fixer Krock: fps goes below 20 in that case
18:45 Fixer Krock: i was thinking the same, i've tried Esc back then too
18:45 Krock Fixer, also happens with pause_fps_max set to default 20. the actual FPS are then 19 usually
18:45 Krock at least on my system
18:46 Fixer Krock: I have exactly 20, but during bug it was below 20, same as with Ihr
18:46 IhrFussel It's not OS specific, the other player uses Win 10
18:47 IhrFussel The config also doesn't matter, the other player has no clue about tech stuff and would never alter the advanced settings
18:47 Fixer Krock: wonder why is your PR stalled? https://github.com/minetest/minetest/pull/6787
18:48 Krock Fixer, nobody cares reviewing, that's all
18:48 Fixer Krock: but it is ready?
18:49 Krock of course, otherwise it'd have an Improve Needed or Testing Needed labal
18:50 Krock IhrFussel, I notice that too the first time I open the inventory but afterwards I get constant 60 fps (today's build)
18:51 Krock perhaps a little stronger GPU or CPU here
18:52 IhrFussel An inventory should never cause such a performance drop, something can't be right if the inventory drops lower than the actual map
18:53 Krock without inventory animations, I believe. It's quite mysterious to me as image/formspec drawing shouldn't take so much processing power
18:53 Krock Fixer, ah I see. needs rebase. going to to that
18:54 IhrFussel The formspec itself doesn't cause any drop I tested it
18:54 IhrFussel I mean I displayed just a formspec with text and no images and there was zero drop
18:56 IhrFussel Krock, the FPS definitely depend on what the inventory displays... sfinv craft grid was at ~ 35 FPS while the All tab dropped to 22 ... now of course I don't have the newest PC but I don't see why it can handle the map data better than the inventory images
18:58 IhrFussel My 0.5.0-dev isn't from today...I can try again with newest commit
19:03 Krock most likely that won't change anything as I get the very same results with an older build
19:20 IhrFussel Can't test MTG sfinv right now but the inventory in minimal also drops FPS (down to ~ 40)
19:25 Mr_Pardison joined #minetest-hub
20:43 Fixer *,,,,,,*
20:43 EvergreenTree joined #minetest-hub
21:00 sys4 joined #minetest-hub
21:10 Mr_Pardison joined #minetest-hub
21:18 red-001 https://forum.minetest.net/​viewtopic.php?f=3&amp;t=52 lol  one of the oldest topics is about minetest vs minecraft
22:09 Fixer HA! https://forum.minetest.net/v​iewtopic.php?f=9&amp;t=19401
22:16 Fixer playername as entity
22:16 Fixer probrem solved
22:37 paramat joined #minetest-hub
22:44 Calinou Fixer: NUL and CON are my favorite players
22:44 Calinou :D
22:44 Fixer lol
22:44 Calinou (there was a bug in minetestserver with players with these names on Windows)
22:44 Calinou it's funny because "nul" and "con" are both words in French
22:44 Calinou the former means "nothing, null", the latter means "dumb"
22:44 Calinou (it's slang)
22:49 nore (the first can mean that someone is not good at something as well; although it is less offensive)
22:53 Fixer nulcom
22:53 Fixer nulcon*
23:02 Calinou nore: yeah
23:12 Fixer https://www.youtube.com/watch?v=​21zZBrSIM1Q&amp;feature=youtu.be
23:13 Fixer great amiga demomusic
23:14 Grandolf joined #minetest-hub
23:15 Fixer https://www.youtube.com/watch?v=a-J24qCqDn4 i have a book with this pic somewhere
23:17 Grandolf hi, when useing minetest.register_alias() is it possible to do something like what is done here: stairs.register_slab(subname, recipeitem, groups, images, desc_slab, sounds)  to the register alias. i want to register all the stairsplus stuff to be stairs. this is what i was trying: minetest.register_alias("stairsplus:slab_" .. subname, "stairs:slab_" .. subname)
23:18 redblade7 joined #minetest-hub
23:20 Fixer https://www.youtube.com/watch?v=wGOvYX6l9n4
23:20 Fixer flightgear actually running on ancient videocard
23:28 Fixer hoooolllyy crappp, i have entered into ancient youtube https://www.youtube.com/watch?v=rbQu4CP2Zk4
23:44 benrob0329 joined #minetest-hub
23:49 benrob0329 o/
23:53 Fixer \o
23:53 Grandolf left #minetest-hub

| Channels | #minetest-hub index | Today | | Google Search | Plaintext